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Copyright © 2018 Xi'an NovaStar Tech Co., Ltd. All Rights Reserved. 

No part of this document may be copied, reproduced, extracted or transmitted in any form or by any 
means without the prior written consent of Xi'an NovaStar Tech Co., Ltd. 

 

Trademark 

 is a trademark of Xi'an NovaStar Tech Co., Ltd. 

 

Statement 

You are welcome to use the product of Xi'an NovaStar Tech Co., Ltd. (hereinafter referred to as 
NovaStar). This document is intended to help you understand and use the product. For accuracy and 
reliability, NovaStar may make improvements and/or changes to this document at any time and without 
notice. Any problem in use or any good suggestion, please contact us through ways provided in the 
document. We will do our utmost to solve the problems and adopt the suggestions after evaluation as 
soon as possible. 
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Change History 

Version Release Date Description 

V3.4.0 2018-08-03 1. Color temperature and color gamut adjustment is 

added. 

2. The advanced mode of hot backup function is 

visualized. 

3. Batch adjustment function is added in the Device 

menu. 

4. The Beacon function is deleted. 

5. UI language supports only Chinese and English. 

V3.2.0 2017-11-30 1. Double seam brightness correction is added in Seam 

Brightness Adjustment. 

2. Monitoring service and platform 

3. Cabinets can rotate in 90° increments. 

4. Beacon 

5. Receiving card program and configuration information 

readback 

V3.1.0 2017-05-25 1. Test Tool is added in the Tools menu. 

2. When the MCTRL R5 is selected, a rotating bar 

appears on each of the cabinets after you add cabinets 

and connect them. 

3. The Batch Add button is added in the tool bar. 

4. The Alignment button is added in the tool bar. 

5. Simple Mode is added to the Hot Backup function. 

6. The Factory Reset sub-menu is added in the Settings 

menu of V-Sender. 

7. Operating wizard is added to the Simple Mode of hot 

backup. 

V3.0.0 2017-01-20 First release 
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1 Introduction 

Overview 

SmartLCT is the new generation of screen configuration software from NovaStar. 
Working with LED display controllers, it allows smart configuration of various complex 
LED displays, including building-block screen configuration, offline (online) design, 
seam brightness adjustment, cabinet rotation, etc. SmartLCT makes screen 
configuration much easier and further enhances user experience. 

Key features: 

 Screen configuration like building blocks 

 Angles of image rotation supports the multiples of 90° (working with the Armor 
series receiving cards). 

 Supports 360° free image rotation (working with the MCTRL R5). 

 Supports 18bit+. 

 Supports ClearView. 

 Supports receiving card program and configuration information readback. 

 Supports the monitoring service and platform. 

 Supports seam brightness adjustment. 

 The functions of video controllers can be set on V-Sender. 

 Supports cabinet brightness and chroma adjustment in batches. 

 Supports hot backup. 

 The canvas can be exported as an image. 

Operating environment: OS X, Windows 7 or later. XI'
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1.1 System Architecture 

 

1.2 Configuration List 

Name Version/Model Function Remarks 

SmartLCT V3.4.0 Operation platform Required 

Supported LED 
display 
controllers 

MCTRL300/MCTRL R5/MCTRL600/MCTRL660 

/MCTRL4K/Thunderview_S1/MCTRL660 PRO 

Send input signals 
to receiving cards 
via Gigabit Ethernet 
ports. 

Optional 

Supported all-in-
one video 
controllers 

3D HD, NovaPro HD 

VX2/VX4/VX4S/K4/K4S/V700/V800/V900/V900S 

Process input 
signals. 

Optional 

Supported 
receiving cards 

MRV200/MRV210/MRV220 

MRV300/MRV320/MRV330/MRV340/ 

MRV350/MRV360/MRV365 

A8s 

Drive the LED 
display. 

Optional 

1.3 Software Installation 

Just like the installation of other common software, install SmartLCT V3.4.0 by 
following the setup wizard. 

 
In case that antivirus software or firewall prompts pop up 
during the installation, please permit them because the serial 
driver may need to be installed. 

 The installation program will update the serial driver on the 
customers' computer to the version of the driver in the 
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installation package automatically if there is no serial driver or 
its version is too early. 

1.4 Notices 
 Mac computers currently do not support MCTRL500, V800, V900 or V900S. 

 Do not support LED display image offset adjustment of MCTRL4K when it works 
in multi-card mode. 

 The V-Sender module does not support the Thunderview_S1 controller. 

 Support the cabinet configuration files (rcfgx) exported from or converted by 
NovaLCT V4.6.0 or later. 

 The Mac computer and the sending device must be set with the same IP 
address and gateway when they are connected by Ethernet cable. 

 Close NovaLCT before using V-Sender to update hardware program of NovaPro 
HD. 

 Disable the auto refresh function on the monitoring configuration page before 
performing firmware update or factory reset operations for sending cards or 
receiving cards. 
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2 User Interface 

Run SmartLCT to enter its start page. 

On the start page, you can create an online or offline project, or open an existing 
project to enter the screen configuration page. 

 

Function Area Description 

Project 
New/Open/Save/Save 
As/Export/Language 

Allows you to create, save, export a project and set 
the system language. 

Device 

Reconnect Device 
Allows you to search for and reconnect a device, 
update hardware information and save it to the 
current file. 

Refresh Device Reads the hardware information again. 

Hot Backup 
Backup between devices and backup between the 
Ethernet ports of a device 

Seam Brightness Adjusts the seam brightness of the LED display. 

Mapping 
Displays the receiving card No. and Ethernet port 
information on the cabinets. 
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Function Area Description 

Test Pattern Verifies the display effect of cabinets. 

Factory Reset Resets the parameters to factory defaults. 

Brightness Adjustment Adjusts brightness of the screen. 

Batch Adjusts cabinet brightness and chroma in batches. 

Edit 

Cabinet Management Allows you to add cabinets and set cabinet size. 

Cabinet Connection Allows you to choose the cabinet connection type. 

Delete Connection Removes the lines between cabinets. 

Advanced 
Allows you to set cabinet display status in the editing 
area and the snapping mode. 

View Includes front view and rear view. 

Send 
Sends the display configuration file to hardware 
devices. 

Save to Hardware(online 
operation) 

Sends and saves the screen configuration file to 
hardware devices. 

Monitor 

Real-Time Monitoring Monitors cabinet status in real time. 

BER Detection 
Detects data packet loss during the communication 
between receiving cards. 

Version Information 
Displays the Ethernet port information and program 
version information of the controllers and receiving 
cards. 

Monitoring Configuration 
Allows you to configure the parameters to be 
monitored. 

Help 

Test Tool 

A LED display test tool developed by NovaStar can 
be used for editing and testing the display window. It 
allows you to open the preview window on the 
desktop and view the result of the test. 

User Manual User manual of SmartLCT 

About Software information 
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3 Language 

SmartLCT is available in German, French, Russian, Spanish, Chinese and English. 

You can change the language through any of the following methods. 

Method I 

In the Function section of the start page, click Language and select the language 
you prefer from the option box that appears. 

 

Method II 

Step 1 In the tool bar of the screen configuration page, choose Project > Language. 

Step 2 Select the language you prefer from the drop-down menu. 
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4 Offline Operation 

4.1 User Interface 

Canvas Properties 

Click a blank area of the canvas and edit the properties of the canvas in the Canvas 
tab. 

 Grid Color: Edit the grid color of the canvas. 

 Grid Width: Set the grid width of the canvas (unit: pixel). 

 Grid Height: Set the grid height of the canvas (unit: pixel). 

 Screen Name: Set the screen name. 

 Disable Edit: Disable all the actions in the canvas. 

Figure 4-1 Canvas properties 
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Screen Color Settings 

Figure 4-2 Color properties 

 

Device Properties 

Click to select a cabinet. The properties of the device are displayed in the Properties 
tab. In the following description, the MCTRL4K is taken as an example. 

Figure 4-3 Device properties 

 

 Connection 1-2-1: Denotes that the sending card No. is 1, Ethernet port No. is 
2, and the receiving card No. is 1. 

 Mapping Position: Position of the target cabinet's top-left corner on the LED 
display 

 Position: Position of the target cabinet's top-left corner on the canvas 
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When the connected device supports rotation function (Currently, only the MCTRL R5 
supports rotation function), the center and angle of rotation can be set in the 
properties of the device to achieve full rotation of the LED display. 

Loading Capacity Usage 

Note: If you have set the connection type to Auto Connect, the cabinets beyond the 
loading capacity of the Ethernet ports cannot be connected. If you choose to 
manually connect the cabinets, the cabinets beyond the loading capacity of the 
Ethernet ports can be connected. 

The Loading Capacity Usage section intuitively displays the usage of the loading 
capacity of Ethernet ports. 

 Blue: Denotes the loading capacity is normal. When the loading capacity of the 
connected cabinets is within that of the Ethernet ports, the progress bar shows 
blue. 

 Red: Denotes the loading capacity is beyond the limit. When the loading 
capacity of the connected cabinets exceeds that of the Ethernet ports, the 
progress bar shows red. 

4.2 New Projects 

Run SmartLCT. In the Function section of the start page, click Create Offline 
Design to enter the Create a new project page. 

Figure 4-4 New projects 

 

 Project Name: Name the project and choose a save path for the project. 
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 Device Selection: Select a video controller. Here the MCTRL1600 is taken as 
an example. 

 Cabinet Selection: Select the manufacturer and type of the cabinets. 

 Screen Size: Set the columns and rows of the cabinets. 

 Max. Load: The maximum screen width and height that can be loaded by the 
device. 

 Connection Type: Select the connection type of the cabinets. You can select 
Auto Connect. 

Cabinet Management 

① Export the selected cabinets: Export the cabinet file. 

② Export all: Export all the cabinet files. 

③ Delete: Delete cabinet files. 

④ Add: Add and import cabinet files. 

⑤ Edit: Edit cabinet files. 

Figure 4-5 Cabinet management 

 

Creating Modes 

You can choose Normal Mode or Smart Mode when creating a new project. 
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 Normal Mode: You only need to edit the project name, choose the save path, 
and select the cabinet. 

 Smart Mode: For details, see 4.2 New Projects. 

4.3 Screen Configuration 

After an offline project is created, you will enter the Edit page. 

4.3.1 Adding Cabinets 

Step 1 Select device type and Ethernet port type. 

Step 2 In the Cabinet Management section, click the cabinet icons. 

 : Clicking this icon allows you to add cabinets in batches. 

 : Clicking this icon allows you to add a single cabinet. 

Step 3 Move the mouse to the canvas, and click-and-drag to add cabinets. 

4.3.2 Cabinet Connection 

Connecting Cabinets 

Before configuring the screen, you need to connect the cabinets. SmartLCT offers 
two connection methods. 

Method I: Auto connect 

On the Create a new project page, after you have selected Auto Connect, the 
cabinets will be automatically connected while you adding them in the canvas. If the 
loading capacity of the cabinets loaded by a single Ethernet exceeds the allowed 
loading capacity of that Ethernet port, auto connection will stop. 

II: Manually connect 

 Add cabinets in the canvas and select the target cabinets. Then, in the Cabinet 
Connection section of the tool bar, choose a cabinet connection type. If the 
loading capacity of the cabinets loaded by a single Ethernet exceeds the allowed 
loading capacity of that Ethernet port, the connection will stop. 

 Add cabinets in the canvas. Then, click to select the center of the first target 
cabinet and then move to the center of the second cabinet, and so forth. 

Note: Choose Edit > Advanced to enable or disable Auto Connect. 

Grouping Cabinets 

Step 1 In the canvas, select the target cabinets and click  (or right click to choose 
Group). 

Step 2 In the Properties section, set the name, color and position for the grouped cabinets. 

The grouped cabinets will be edited as a whole. 
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Figure 4-6 Grouping cabinets 

 

Deleting Cabinet Connection 

Select the target cabinets and click  in the tool bar (or right click to choose 
Delete Connection) to remove the connection between the cabinets. 

Setting Cabinet Offset 

After you have added cabinets and connected them, a dotted rectangle surrounding 
the cabinets will appear. The size of the dotted rectangle denotes the loading 
capacity of the currently connected device. 

oordinate system will be generated in the canvas. 

Step 1 Click , and you can drag a cabinet to change its position relative to the dashed 
box.  

Step 2 Click  to quit the edit. 
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Figure 4-7 Setting cabinet offset 

 

Figure 4-8 Quitting editing 

 

Rotating Cabinets 

When the added device supports rotation function, rotate the cabinets according to 
the following steps. The MCTRL R5 is taken as an example. 

Step 1 Click . Click and rotate the rotation bar (or set the angle of rotation) to rotate the 
cabinets to the target position. 

Step 2 Click  to quit the edit. 
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Figure 4-9 Rotating cabinets 

 

Figure 4-10 Quit editing 

 

4.4 Sending Configuration Information 

Step 1 In the tool bar, click . 

Step 2 Click Yes in the prompt box that appears. 

Figure 4-11 Prompt box 
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Step 3 In the Match Device dialog box that appears, select the matched online device. 

Figure 4-12 Matching device 

 

Step 4 Click OK.
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4.5 Other Operations 

4.5.1 Adding Devices 

Step 1 At the bottom left of the Device section, click . The Add Devices dialog box 
appears. 

Step 2 Select device type, enter the number of the devices to be cascaded, and then click 
Add. 

Step 3 Click OK. 

4.5.2 Hot Backup 

Choose Device > Hot Backup. The Hot Backup page appears. For detailed 
operation, see the page navigation. 

The hot backup includes backup with the device (Ethernet port backup) and backup 
between devices. 

 Hot backup is only available for the devices with the same communication ports. 

 After device backup is set, the Ethernet ports of the backup device will be the 
backup of the corresponding ports of the master device. The backup relations 
cannot be crossed and removed. 

Backup Within the Device 

Step 1 Add a device to the editing area. 

Step 2 Click , as shown in the figure below. 

 

Note: 

 When the Ethernet ports are backed up, click  at the top right of the device to 
remove the backup. 

 Click  between two Ethernet ports to delete the line. 

 Click  at the top right of the device to delete the device. 

 Backup Between Devices 

Step 1 Add devices that requires backup to the editing area. 

Step 2 Drag a device onto another device, and the backup can be done automatically. Or 
click the small triangle in the right side of the device, drag to the small triangle of the 
other device and click to complete the backup. 

Note: 
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 When the backup is done, the  icon appears on the line between the two 
devices. Click this icon to switch between master and backup. 

 Click  at the top right of a device to delete the device. 

 Click  at the top right of the dashed box to remove the backup. 

 

Switch Between Master and Slave Devices 

Before backup, click the toggle button on the right of a device to set it as the master 
device or backup device. 

 

Table 4-1 Ethernet port description 

Icon Description Icon Description 

 Connection of the 
primary port is not 
available. 

 Connection of the primary port is 
available. 

 The backup port is 
enabled. 

 The port is not backed up. 

 The backup port is not 
enabled. 

 The port is backed up. 

 Backup device  Master device 
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5 Online Operation 

5.1 User Interface 

Canvas Properties 

Click a blank area of the canvas and edit canvas properties in the Canvas section.  

 Grid Color: Edit the grid color of the canvas. 

 Grid Width: Set the grid width of the canvas (unit: pixel). 

 Grid Height: Set the grid height of the canvas (unit: pixel). 

 Screen Name: Set the screen name. 

 Disable Edit: Disable all the actions in the canvas. 

Figure 5-1 Canvas properties 

 

Screen Color Settings 

This is used to set color parameters of the screen. 

 Supports custom brightness, Gamma and color temperature. 

 Supports 18 bit grayscale mode. 

 Supports ClearView. 

 Supports calibration type selection. 

 Supports custom color gamut. 

 Supports PAL or NTSC. 
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Figure 5-2 Color properties 

 

Figure 5-3 Color gamut settings 
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Table 5-1 Description of color gamut settings page 

Name Description 

Tool bar 

 
Enable editing. 

 Disable editing. 

 
Zoom in editing area. 

 
Zoom out editing area. 

 
Import configuration files. 

 Export the parameters as a configuration file. 

 Reset the color information. 

Editing area Click-and-drag the enabling point to set target color gamut. 

 
Close the color gamut adjustment. 

 
Save the color gamut parameters. 

/  Analog television color system 
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Send Send color gamut parameters to user terminals. 

Send to HW Save color gamut parameters to the sending device. 

Device Properties 

Click to select a cabinet. The properties of the device is displayed in the Properties 
tab. In the following description, the MCTRL4K is taken as an example. 

 Connection 2-1-11: Denotes that the sending card No. is 2, Ethernet port No. is 
1, and the receiving card No. is 11. 

 Mapping Position: Position of the selected cabinet's top-left corner on the LED 
display. 

 Position: Position of the selected cabinet's top-left corner on the canvas 

 Test Pattern: This is used for verifying the display effect of the screen. 

 Program Version: This is used to refresh, download or upgrade the version of 
the receiving card program. 

− : Read back the version of the receiving card firmware for a single 
cabinet. 

− : Read back the firmware program of the receiving card for a single 
cabinet. 

− : Upgrade receiving card firmware program for a single or multiple 
cabinets. 

 Serial No.: Serial number of the device. 

 Module details: This is used to show operating status of the module. 
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When the connected device supports rotation function (Currently, only the MCTRL R5 
supports rotation function), the center and angle of rotation can be set in the 
properties of the device to achieve full rotation of the LED display. 

Advanced Settings 

On the Advanced tab page, you can set the prestored image and the startup screen 
status. 

 Prestored image settings 

a. Click Browse to add an image. 

b. Set the image effect and select Preview. 

c. Click Apply to save the settings. 

d. Click Open. The LED display will show the prestored image. 

 Function settings 

− Enable/Disable the startup screen function. 

− Set the duration to play the startup screen image.  

− Set the LED display playback status on startup for the situation where the 
Ethernet cable is disconnected. 

− Set the LED display playback status on startup for the situation where there 
are no DVI signals. 
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Loading Capacity Usage 

The Loading Capacity Usage section displays the usage of the loading capacity of 
Ethernet ports. 

 Blue: Denotes the loading capacity is normal. The length of the blue bar 
indicates the used capacity of the Ethernet port. 

 Red: Beyond the loading capacity. Cabinets exceeding the loading capacity 
cannot be connected. 

5.2 New Projects 

Step 1 Run SmartLCT. On the start page, click  next to Device List to refresh the device 
list and screen list. 

Step 2 In the Function section, click Create Online Design to enter the Create a new 
project page. 
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 Project Name: Name the project and choose a save path for the project. 

 Cabinet Selection: Select the manufacturer and type of the cabinets. 

 Screen Size: Set the columns and rows of the cabinets. 

 Max. Load: The maximum screen width and height that can be loaded by the 
device. 

 Connection Type: Select the connection type of the cabinets.  

5.3 Screen Configuration 

After an online design is created, the edit page will be displayed. 

5.3.1 Adding Cabinets 

If the system is connected with receiving cards, it can read the cabinet size 
automatically. 

Step 1 Select an Ethernet port type. 

Step 2 In the Cabinet Management section, click the cabinet icons. 

 : Clicking this icon allows you to add cabinets in batches. 

 : Clicking this icon allows you to add a single cabinet. 

Step 3 Move the mouse to the canvas, and click-and-drag to add cabinets. 
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5.3.2 Cabinet Connection 

For detailed operation of cabinet configuration, see 4.3.2 Cabinet Connection. 

5.4 Seam Brightness Adjustment 

Before you begin: Configure the LED display (that is, add cabinets and connect 
them). 

5.4.1 User Interface 

Figure 5-4 Seam brightness adjustment page 

 

Figure 5-5 Tool bar introduction 

 

Tools Description 

Module mode Split the added cabinet into different areas (modules). 
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Cabinet mode Recover the split cabinet. 

Select border 

Select row and column/Select row/Select column/Select single 
border/double borders 

Demonstration: 

Choose Row Selection, then click-and-drag to choose the 
cabinet or click to choose horizontal borders of the cabinet. 

Clear status 
Clear selected status/Clear effect of all borders /Clear effect of 
selected borders 

Keyboard 
Shortcuts 

Set keyboard shortcuts 

Set keyboard shortcuts and use them for cabinet mode selection 
and borders settings. 

Figure 5-6 Setting of shortcuts 

 

Figure 5-7 Tool bar introduction 

 

Tools Description 
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Show screen 
Window 

Show (or hide) display window. 

Show Dashed 
Box 

Show (or hide) dashed box of the selected borders. 

Show Number Show (or hide) serial number of the display window. 

Calibration 
Type 

Close calibration/Chroma calibration/Brightness calibration 

Close calibration: The effect of seam brightness adjustment is 
not shown on the screen. 

Chroma calibration/Brightness calibration: Screen calibration 
modes. 

Image Quality 
Adjustment 

Red/Green/Blue/White 

Testing color on the display window (or LED screen) 

Screen Display 
Position 

Switch position of the display window. 

Description of Border Colors 

Gray Indicates the LED is not 
selected and the 
parameter is not adjusted. 

Blue Indicates the LED is 
selected and the 
parameter is not adjusted. 

Light green Indicates the LED is not 
selected and the 
parameter is already 
adjusted. 

Dark green Indicates the LED is 
selected and the 
parameter is already 
adjusted. 

5.4.2 Seam Brightness Parameter Adjustment 

Step 1 Choose Device > Seam Brightness to enter the seam brightness adjustment page. 

Step 2 Select the target border, and the border will become blue. 

Step 3 (Optional) Choose precision of the adjustment. 

Step 4 Drag the slider next to the Selected Area Parameter Adjustment to adjust seam 
brightness parameters, and the borders will become green. 

Step 5 Type “admin” to access the factory area and user area settings page. 

 Save to Factory Area: Save seam brightness adjustment parameters to the 
factory area of the receiving card. These parameters will be used for 
maintenance after the cabinet is returned to factory. 

 Save to User Area: Save seam brightness adjustment parameters to the user 
area of the receiving card. These parameters will be used for on-site screen 
adjustment. 

 Load Factory Area: Restore seam brightness adjustment parameters to the 
parameters last saved in the factory area. 

 Load User Area: Restore seam brightness adjustment parameters to the 
parameters last saved in the user area. 
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 Save to HW: Save seam brightness adjustment parameters to the sending 
device. 

 Save: Save the seam brightness adjustment parameters. 

Step 6 Save seam brightness adjustment parameters to the sending device. 

 

5.5 Batch Adjustment 

This function is used to adjust the brightness and chroma of cabinets of different 
batches in order to ensure the images are displayed uniformly on LED screen.  

Before you begin: Configure the LED display and save the configuration parameters 
to hardware. 
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Table 5-2 Batch adjustment description 

Area Description 

Tool Bar 

Import: Import the batch adjustment parameter file. 

Export: Save the adjustment parameters of current batch to 
local PC. 

Screen Display: Set the window to display on the main display 
or extended display. 

Calibration Type: Choose the type of display calibration. 

Window Switch: Show/Hide the display window. 

Save: Save the batch adjustment parameters as a file. 

Save to HW: Save the batch adjustment parameters to 
hardware. 

Editing Area 
Edit the status of cabinets or modules (double-click on the 
cabinet to enter the module view) displayed in the area. 

Batch Editing 
Area 

Two batches are added in this area by default when you perform 
batch adjustment for the first time. 

Click  to add a batch. 

Click  to select all batches. The statuses of cabinets in each 
batch are displayed on the display window. 

Brightness 
Adjustment 
Area 

Adjust cabinet brightness parameters. 

Chroma 
Adjustment 
Area 

Adjust cabinet chroma parameters. 
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Procedures 

Step 1 Select a target batch. 

Step 2 In the editing area, select the target cabinets or modules, and then click Add to 
Sample Area. 

Step 3 Adjust chroma and brightness.  

Step 4 Click Apply Adjustment.  

Step 5 Click Save to HW. 

Note: Each batch must have the sample area information. 

5.6 Monitoring 

Click Refresh to refresh the monitoring information of current system. 

Real-Time 

Monitoring 

Monitors the real-time status of the hardware devices such as 

receiving cards, multifunction cards. 

BER Detection Detects data packet loss during the communication between receiving 

cards. 

Version 

Information 

Displays the device type, communication port status major version and 

other versions of the controllers and receiving cards. 

Monitoring 

Configuration 

Allows you to configure the information to be monitored. 

5.6.1 Real-Time Monitoring 

 

A: Canvas, where the real-time statuses of cabinets are displayed. 

In the canvas, move the mouse and point to a cabinet. The current status of the 
cabinet will be displayed. Double clicking the target cabinet allows you to view the 
real-time status of the device and parameters, as shown in the figure below. 
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B: Monitoring area, where the status statistics of the parameters are displayed. 

C: Device area, where the real-time connection status of the device being monitored 
is displayed. 

In the device area, move the mouse and point to the device icon. The working status 
of the device is displayed. Clicking the device icon allows you to view the hot backup 
status of the device and Ethernet ports and the working status of the signal sources. 

5.6.2 BER Detection 

The statistics of data packet loss during communication between receiving cards is 
called Bit Error Rate (BER), which is shown by a line chart in the canvas. 

Clicking Refresh will refresh the BER of current period so that users can observe the 
stability of network communication. 

5.6.3 Version Information 

Clicking  on the right of Controller or Receiving Card will refresh the version 
information. 

Clicking  will refresh the version information of the Controller and 
Receiving Card simultaneously. 

5.6.4 Monitoring Configuration 

Basic Information 

You can configure the refresh rules for the real-time monitoring. 

Select Auto refresh, and the monitoring information will be automatically refreshed 
based on the Refresh cycle and the times of Retry you set. 

When the Auto refresh is not selected, you need to refresh the monitoring 
information manually. 
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Device Configuration 

Device configuration allows you to configure the Hot backup status and Signal 
source status of the device for real-time monitoring. 

 If Hot backup status is selected, the hot backup status of the device will be 
monitored in real time. 

 If Signal source status is selected, clicking Configuration allows you to select 
the signal source to be monitored. 

Screen Configuration 

Step 1 Select the target devices (monitoring card, smart module and HUB). 

Step 2 Click Configuration to configure the corresponding parameter. 

Step 3 Adjust monitoring parameters. 

 In the Threshold column, drag the slider to adjust the threshold. 

 In the Error Detection column, selected parameters are added to Real-Time 
Monitoring. 

Step 4 Click Save. 

 

Threshold description: Green denotes normal, yellow denotes alarm, and red denotes 
error. 

Type Threshold Description 

Temperature When the temperature is higher than 66°C, you will see a temperature 

alarm in the real-time monitoring. 

Humidity When the temperature is higher than 60%, you will see a humidity 

alarm in the real-time monitoring. 

Voltage When the voltage is lower than 3.40 V, you will see a voltage error in the 

real-time monitoring. When the voltage is higher than 3.40 V and lower 

than 3.80 V, or higher than 5.50 V, you will see a voltage alarm in the 

real-time monitoring. 

Fan When the fan speed is lower than 1000 r/m, you will see a fan alarm in 

the real-time monitoring. 

Note: The figure above only shows some of the monitoring types. The meanings of 
the thresholds of other types are similar. 

5.7 Sending Configuration Information 

Step 1 In the tool bar, click . 

Step 2 In the prompt box that appears, click OK. 
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5.8 V-Sender 

V-Sender allows you to set the status of the current device and operate the device on 
PC. 

Supported devices include MCTRL300 (MSD300), MCTRL660, VX4S, Pro HD, 3D 
HD, and MCTRL4K. 

5.8.1 Accessing V-Sender 

Method I 

On the start page, click  in the Device List section to access V-Sender, as 
shown in the figure below. 

 

Method II 

In the Device section of the editing page, click  to access V-Sender, as shown 
in the figure below. 
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5.8.2 Introduction to Tool Bar 

 

 : Reconnect the device after the device went offline. 

 : Refresh the device information 

 : Reset to factory settings. 

 : Send current device information to the hardware device and save it. 

 : Update the firmware version of current controller device. 

 : Test the display effect of the images displayed on LED screen. 

 : Set the temperature and voltage ranges for normal operating of 
current controller device. 

 : Set the UI language of current page. 
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5.8.3 Adding Devices 

Step 1 At the bottom of the device list, click . The Add Devices page 
appears. 

Step 2 Select the devices you want to add and click OK. 

 

Device Information 

 

Ethernet Port Status 

The Information tab at the bottom of the canvas displays the status of Ethernet 
ports. 

Port Status Icon Description 

Backed up but not 

connected  
This Ethernet port serves as the primary port and is not 

connected to the receiving card. 

Not backed up 

and not 

connected 

 
This Ethernet port serves as the primary port and is not 

connected to the receiving card. 

Backed up and 
 

This Ethernet port serves as the backup port and is 
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connected connected to the receiving card. 

Not backed up 

but connected  
This Ethernet port serves as the backup port and is not 

connected to the receiving card. 

Backup takes 

effect. 
 

This Ethernet port serves as the backup port which takes 

effect (indicating the Ethernet cable is disconnected). 

5.8.4 Screen Control 

At the bottom of canvas, the Control tab displays the input sources of the main 
screen and minor screen, and the methods of screen control. (The figure below takes 
the K4S as an example.) 

Meanings of the options of Screen Control: 

 Black Out: The LED display goes black. 

 Freeze: The current content being displayed pauses. 

 Normal: The current content is displayed normally. 

 Test Pattern: Allows you to verify the display effect of the screen with different 
test patterns. 

 

5.8.5 Template Settings 

Select a template on the Template tab below the canvas and click  to save 
current configuration parameters as a template. You can save up to 10 templates by 
default. 

 

 Clicking  will save current configuration parameters to any of the templates. 

 Clicking  will delete the selected template. 

5.8.6 Device Properties 

After you set the Input, Color and Output, clicking Apply will complete the settings. 

Option Description 

Properties Displays the device's type, communication port, ID, hardware program 
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version. Change the device name and upgrade the firmware version of 

currently connected controller device. 

Input Set the input source type, data bits and input source resolution. Displays 

the resolution of current input source. 

Color Used for adjusting the screen color 

Output Mosaic: If the number of the pixels of the LED display exceeds the 

loading capacity of the device, the mosaic function is required. For 

detailed operation, see 5.8.8 Mosaic. 

Note: When Mosaic is selected, the Disable Zoom, Auo Fit, Video 

Source Synchronization options under Main Screen are hidden. 

Main Screen: Used for setting the parameters of the main screen, such 

as capture, output size, output position 

Minor Screen: Used for setting the parameters of the minor screen, 

such as capture, output size, output position, transparency 

Video Source Synchronization: Syncs the parameters of input and 

output video sources. 

System Used for system parameter settings 

Meanings of the parameters: 

 LCD Lock: Locks the operation screen of the device. After the 

operation screen is locked, buttons on the device are disabled. 

 Smart Gray Scale: Adjusts the grayscale of the LED display. 

 Deinterlace: Restores the interlaced video signal to progressive 

signal. 

 VGA Auto Adjusting: Adjusts the sampling parameters of VGA input 

signal automatically. 

 ADC Auto Calibration: Adjusts color cast, dimming and other display 

problems. 

Audio Used for enabling and disabling audio output and adjusting audio output 

parameters 

Audio types: 

 Following Mode: Uses the audio source of HDMI. 

 Constant Mode: Uses the external audio source. 

5.8.7 Picture in Picture (PIP) 

Connect a video controller which supports PIP function. Then, enter the V-Sender 
page and select the PIP tab in the canvas. 

Click the different icons in the tool bar to adjust the layout of the main screen and 
minor screen, as shown in the figure below. 

Note: Move the mouse to the canvas. When the mouse pointer changes into a double arrow, 
click and drag to change the size of the main screen or minor screen. 
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Tool Bar Icon Description 

Cancel  Cancels the results of a previous action. 

Revert  
Restores the results of a previous action 
that was canceled. 

Zoom in  Zooms in view. 

Zoom out  Zooms out view. 

Main and Minor Screens 
Switching  

Switches between main and minor 
screens. 

Horizontal Layout  N/C 

Vertical Layout  N/C 

In the Middle  
N/C 

Upper Left Layout  N/C 

Lower Left Layout  N/C 

Upper Right Layout  
N/C 

Lower Right Layout  N/C 

Main Screen Settings 

You can set the zoom status of the main screen. Three options are provided: Disable 
Zoom, Customize Zoom and Auto Fit. 

 Disable Zoom: The size of input image is the same as the size of the output 
image and only the image offset position is settable. 
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 Customize Zoom: Allows you to set the start position and size for Capture. The 
captured content will be displayed on the LED display. Output Size is the size of 
the main screen in the canvas. Output Position is the start position of the 
current main screen in the canvas. 

 

 Auto Fit: The input image is zoomed to fit the main screen automatically. This 
mode is suitable for full screen display. 

 

 Selecting Apply to All will apply the settings to all the input sources. 

After the settings are done, clicking Apply will send the current configuration 
information to the input source. 

Minor Screen Settings 

The size and position of the minor screen are editable. Selecting Capture allows you 
to set the size and start position of the content to be captured. The captured content 
will be displayed on the LED display. 
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After the settings are done, clicking Apply will send the current configuration 
information to the signal source. 

Video Source Synchronization 

Video source synchronization allows you to sync the input video source with the 
output video source. 

5.8.8 Mosaic 

Before you begin: When the pixels of the output image exceeds the loading capacity 
of a single device, the mosaic function will be required. 

Step 1 Access V-Sender. On the Output tab, select Mosaic. 

Step 2 Set parameters through any of the following methods. 

 Non-Equal Division: When the loading capacities of each of the VX4S units are 
different, set the total number of pixels of the LED display, the loading area of 
current device and the start position. 

 Equal Division: When the loading capacities of each of the VX4S units are the 
same, set the total number of pixels of the LED display, the number of mosaic 
rows and columns, and the start position of the loading area of the current 
device. 

Step 3 After the parameter settings are done, click Apply to send the settings to hardware. 
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5.9 Other Operations 

5.9.1 Hot Backup 

For the detailed operation of hot backup, see 4.5.2 Hot Backup. 

5.9.2 Mapping 

SmartLCT supports the Mapping function. 

Choose Device > Mapping. The receiving card numbers and Ethernet port 
information are displayed on the cabinets of the screen.
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6 Features 

6.1 Building Screens like Building Blocks 

Step 1 In the Device section, select a device and Ethernet port. 

Step 2 In the tool bar, choose Edit > Cabinet Management >  or . 

Step 3 Move the mouse to the canvas and click to add cabinets. 

Step 4 Select one or multiple cabinets and move the mouse to change the position of the 
cabinet(s). Build different shapes of screens as required. 

6.2 Rotating in 90° Increments 

Before you begin: Connect the receiving cards or controllers that support rotation to 
SmartLCT, for example, A8s. 

Step 1 In the canvas, select the target cabinet. 

Step 2 In the property area, click Reorient to select the angle of cabinet rotation (0°, 90°, 
180°, 270°). 

6.3 Full 360° Rotation 

Before you begin: Connect the controller MCTRL R5 to SmartLCT, and the rotation 
function can be enabled. 

Rotation of a Single Cabinet 

Step 1 Click  and select the cabinets. A rotating bar appears on each of the cabinets. 

Step 2 Select any of the rotating bars and drag the mouse. The cabinet rotates around its 
rotation center. 

Step 3 (Optional) Set the rotation center and angles of rotation in the property section on the 
right. 
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Rotation of Grouped Cabinets 

Step 1 Click  and select the target cabinets. 

Step 2 Right click the cabinets and choose Group. 

Step 3 Click to select the grouped cabinets. A rotation bar appears on the rotation center of 
the grouped cabinets. 

Step 4 Click the rotation bar and drag the cabinets. The group of cabinets rotates around the 
rotation center. 

Step 5 (Optional) Set the rotation center and angles of rotation in the property section on the 
right. 
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6.4 LED Display Test 

Choose Tools > Test Tool to enter the display test tool page (that is, receiving card 
test page). 

Note: Display test is only available for Windows. 

 

 Window: Set window position and size, or hide the window. 

 Pure Color: Set window color (pure color), grayscale and refresh rate. 

 Gradient: Set the gradient color and levels of the window. 

 Grid: Set grid and color and other parameters of the window. 
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 Orientation: Set module size and the number of modules loaded by the 
scanning board. Detailed settings are shown in the figure below. 

 

 Help: Keyboard shortcus for quick operations. 

 About: LED display solutions. See detials in the figure below. 

 

6.5 Update and Readback of Receiving Card Configuration 
Parameters 

Save receiving card parameter configuration files to the local PC. 

Step 1 In the canvas, select the target cabinet(s). 

Step 2 Right-click to select Read back parameters/Update receiving card parameters to 
read back or update local receiving card configuration parameters. 

6.6 Readback of Controller and Receiving Card Inforamtion 

Choose Monitor > Version. Click  next to the corresponding controller or 
receiving card to read back the model, communication port and hardware version of 
the current controller or receiving card. 
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6.7 Receiving Card Program Upgrade 

Before you begin: Save the upgrade package of receiving card firmware program to 
the local PC. 

Step 1 In the canvas, select the target cabinet(s) to enter the Properties tab page on the 
right. 

Step 2 Click  next to Program Version. 

Step 3 Select the path of the upgrade package to upgrade the firmware program. 

6.8 Controller Program Upgrade 

Before you begin: Save the upgrade package of the controller firmware program to 
the local PC. 

Step 1 Enter V-Sender. 

Step 2 Click Update, or select the Properties tab and click  next to Program Version. 

Step 3 On the Firmware Upgrade window that appears, click  to select the path of the 
upgrade package. 

Step 4 Click Update. 

6.9 Exporting Screen Configuration Information as Image 

The screen configuration information can be exported as an image,  

Step 1 Choose Project > Export. The Export page appears. 

Step 2 Set export parameters and information. 

 

Step 3 Click Export to export the image to the local PC. 
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